Start map for BMW S14 needed

Post maps up for others to get them going in the right direction. DISCLAIMER: USE AT YOUR OWN RISK. CONFIRM VALUES!

Re: Start map for BMW S14 needed

Postby lofstrom » Thu Oct 06, 2016 7:34 am

Sorry, my bad. I've played around with some of the parameters so I got confused. The tooth number is now set to 60 but it doesn't help. I've attached the updated map and an Oscilloscope image. Any advice is appriciated.

Thanks!

/Stefan
Attachments
BMW_S14_stefan_161006.map
(41.36 KiB) Downloaded 138 times
2016-10-05.jpg
lofstrom
 
Posts: 27
Joined: Sun May 29, 2016 12:48 am
Location: Sweden
ECU Model: S40 Pro

Re: Start map for BMW S14 needed

Postby iceman_n » Thu Oct 06, 2016 9:35 am

do again the oscilloscope procedure and write the details on orange square as on the pic i post
Attachments
part4_diagram_2.jpg
iceman_n
 
Posts: 135
Joined: Mon Jan 16, 2012 1:39 pm
ECU Model: S40 Pro
Firmware Version: 58

Re: Start map for BMW S14 needed

Postby Rob Stevens » Thu Oct 06, 2016 9:45 am

You need to put the plugs in to estimate the crank sensor position also
Rob Stevens
 
Posts: 1067
Joined: Thu Jul 28, 2011 4:10 am
ECU Model: S100 Pro
Distributor: None-Coil On Plug :)

Re: Start map for BMW S14 needed

Postby Alex DTA » Thu Oct 06, 2016 1:10 pm

You're getting a good crank signal. Next step is to check it's synchronising.
Have a look at this video:
https://www.youtube.com/watch?v=Ku2eddSHBrs

Does your label turn green in the Diagnostics Display?

Also check the coils and injectors are firing using the test auxiliary functions.
Alex DTA
 
Posts: 1424
Joined: Fri Feb 28, 2014 1:03 pm
ECU Model: S40 Pro
Distributor: DTA
Firmware Version: 79

Re: Start map for BMW S14 needed

Postby lofstrom » Fri Oct 07, 2016 1:17 pm

Guys,

attached are some print screens. If I want to do the coil and injector test, what is the best way not to flood the engine? Remove the fuel pump relay or fuse?

Thanks for the video, interesting stuff!

/Stefan
Attachments
oscilloscope with spark plugs but without injectors connected 2016-10-07.jpg
oscilloscope with spark plugs 2016-10-07.jpg
diagnostic without spark plugs 2016-10-07.jpg
oscilloscope without spark plugs 2016-10-07.jpg
lofstrom
 
Posts: 27
Joined: Sun May 29, 2016 12:48 am
Location: Sweden
ECU Model: S40 Pro

Re: Start map for BMW S14 needed

Postby iceman_n » Fri Oct 07, 2016 2:02 pm

ok cool...use 117 sensor position, i prefer it instead of 297

to test the coils and injectors...just remove injectors and place them into a bottle then do the test otherwise you will flood the engine...

with coils just ground them on engine with a spark plug inside them and watch if it sparks...do it for each coil

hope all the other settings to be correct...and try again to see if ecu synchronise, red must be green...

READ them manual too...
iceman_n
 
Posts: 135
Joined: Mon Jan 16, 2012 1:39 pm
ECU Model: S40 Pro
Firmware Version: 58

Re: Start map for BMW S14 needed

Postby Alex DTA » Sat Oct 08, 2016 12:10 am

Did the diagnostics screen show that the ECU synchronised?
Alex DTA
 
Posts: 1424
Joined: Fri Feb 28, 2014 1:03 pm
ECU Model: S40 Pro
Distributor: DTA
Firmware Version: 79

Re: Start map for BMW S14 needed

Postby lofstrom » Sat Oct 08, 2016 2:55 pm

Guys,

I did some additional testing in the garage tonight. The results are:

1. It's not synchronizing, I never get a green label. BTW, what does synchonize mean in this context?

2. before we attempted to start the engine we did try a strobe lamp (timing light) attached to #1 spark plug wire, but it never gave any strobe.

3. We did ground the spark plugs and could see a spark on #1-3 but not on #4

4. Tonight I did the coil test function and I could hear the coil pack making some ticking sounds

5. I also removed the fuel rail and all injectors and tried the injector test function with just one injector connected. There were about three drops of fuel in the can so something is not correct. I also tcranked to see if there were any spray. Or do I need to have all four injectores connected? It seems tricky to lift up the complete fuel rail assy and get 4 cans in place for each injector. Is the injetor type important? I run the original ones.

Any ideas? Do I have two independent issues, one with synchronizing and one with fuel???

Also I have read the manual, but it doesn't really help me....

Regards,
Stefan
lofstrom
 
Posts: 27
Joined: Sun May 29, 2016 12:48 am
Location: Sweden
ECU Model: S40 Pro

Re: Start map for BMW S14 needed

Postby katana » Sun Oct 09, 2016 3:17 am

Synching is needed if sequential fueling / sparking required. Without the ecu know where TDC point is but not know if its 1 or 4 that is firing. Using batch fire and wasted spark obviates that problem. Injector test doesn't need fuel or dismantling the injectors - just unplug pump relay and you should be able to hear injectors clicking as requested in software BUT not for too long as they can overheat without fuel flow through them.
katana
 
Posts: 351
Joined: Sun Jan 27, 2013 6:08 pm
ECU Model: S60 Pro
Firmware Version: 29

Re: Start map for BMW S14 needed

Postby Alex DTA » Sun Oct 09, 2016 4:36 am

1. If it's not synchronising, the ECU won't turn on any outputs, as it can't work out where anything is. This applies to batch and sequential firing.
2. See above.
3. That must have been using the test functions. If you are using a wasted spark coil pack, you either have a faulty coil pack, spark lead or spark plug.
4. Sounds fine.
5. You won't get much fuel out unless you also turn on the fuel pump. There won't be much pressure if the engine hasn't run. This is normal.

Until you have synchronisation, changing other things won't help. You must sort out the synchronisation before anything else will happen.
Attached is a copy of your map. All I've done is changed the number of teeth and crank sensor angle. This should synchronise with your oscilloscope straight away.
Upload it, then click the Reset button on the Diagnostics Display, and then try to start the car. Video it so we can see what's happening.
Attachments
BMW_S14_stefanDTA.map
(41.32 KiB) Downloaded 160 times
Alex DTA
 
Posts: 1424
Joined: Fri Feb 28, 2014 1:03 pm
ECU Model: S40 Pro
Distributor: DTA
Firmware Version: 79

PreviousNext

Return to Shared Maps

Who is online

Users browsing this forum: No registered users and 3 guests