It is currently Mon Aug 20, 2018 6:05 pm



Post new topic Reply to topic  [ 26 posts ]  Go to page 1, 2, 3  Next
Author Message
 Post subject: S60 on a Suzuki Gsxr1000 K3/4
PostPosted: Tue May 09, 2017 2:11 pm 
Offline

Joined: Sat Apr 18, 2015 7:26 am
Posts: 11
Location: Sussex
ECU Model: S60 Pro
Help I am struggling I have sparks and injection on the test settings, but cant get the motor to start on all 4 cylinders only wants to run on cylinder 1 and 2 I am trying to run fully sequential I noted that the ignition rotor has 24 teeth but no missing teeth only a large uncut blank. and advice would be appreciated Thanks in advance Andy


Top
 Profile  
 
 Post subject: Re: S60 on a Suzuki Gsxr1000 K3/4
PostPosted: Tue May 09, 2017 2:35 pm 
Offline

Joined: Tue Aug 02, 2011 12:08 pm
Posts: 2883
Location: Norn Iron
ECU Model: No ECU
photos...details...information.

Help us help you.

Upload the map you are trying to use, give us some more detail. Most may not be familiar with your exact engine. What sort of crank sensor does it use, is it all wired correctly ? Are you getting a stable rpm reading ?
Can you provide an oscilloscope trace ( P8 does not offer this feature so will need to be from a proper scope )

Are you getting crank sensor errors etc ?

You say there are 24 distinct teeth... AND or including a large uncut blank ? post a photo. Any area that does not have distinct teeth would generally bee seen as missing teeth.

Do you have a cam/phase sensor at all ? Or are you trying to run it wasted spark ? Is it wired accordingly ?


Top
 Profile  
 
 Post subject: Re: S60 on a Suzuki Gsxr1000 K3/4
PostPosted: Tue May 09, 2017 2:56 pm 
Offline

Joined: Thu Jul 28, 2011 4:10 am
Posts: 839
ECU Model: S100 Pro
My advice would be to not worry about sequential yet. If ever. Unless you have a very specific reason. It makes bugger all difference to full power.
Can you confirm how you have wired the coils, i.e. what output to what cylinder? as per the drawing? Likewise the injectors.
Does it have 2 injectors per cylinder?
The coil wiring should be as per the twin spark settings for simplicity as you don't have an odd firing engine, this way it will work in sequential and nonsequential (cop). And select twin spark in general engine settings.
Coil o/p1 = Cylinder 1
Coil o/p2 = Cylinder 3
Coil o/p5 = Cylinder 4
Coil o/p6 = Cylinder 2


Top
 Profile  
 
 Post subject: Re: S60 on a Suzuki Gsxr1000 K3/4
PostPosted: Wed May 10, 2017 1:23 pm 
Offline

Joined: Sun Jan 27, 2013 6:08 pm
Posts: 254
ECU Model: S60 Pro
Firmware Version: 29
1127r wrote:
Help I am struggling I have sparks and injection on the test settings, but cant get the motor to start on all 4 cylinders only wants to run on cylinder 1 and 2 I am trying to run fully sequential I noted that the ignition rotor has 24 teeth but no missing teeth only a large uncut blank. and advice would be appreciated Thanks in advance Andy


If i'm right from your description it sounds like you are trying to use the std Suzuki wheel........it won't work successfully. Not sure if the K3/4 has a cam sensor which is required for full sequential control.


Top
 Profile  
 
 Post subject: Re: S60 on a Suzuki Gsxr1000 K3/4
PostPosted: Wed May 10, 2017 2:39 pm 
Offline

Joined: Fri Feb 28, 2014 1:03 pm
Posts: 1074
ECU Model: S40 Pro
Distributor: DTA
Firmware Version: 79
Post a crank scope.

As katana says, there are a few Kawasaki engines where the gap is in the wrong place, and the ECU struggles to read it.
Once I've got the software rewrite complete, it's one of the things I want to look at improving.


Top
 Profile  
 
 Post subject: Re: S60 on a Suzuki Gsxr1000 K3/4
PostPosted: Thu May 11, 2017 2:33 am 
Offline

Joined: Thu Jul 28, 2011 4:10 am
Posts: 839
ECU Model: S100 Pro
He's on a P8 so doesn't have that luxury. but it sounds like its running but only on 2 cylinders


Top
 Profile  
 
 Post subject: Re: S60 on a Suzuki Gsxr1000 K3/4
PostPosted: Thu May 11, 2017 2:49 am 
Offline

Joined: Fri Feb 28, 2014 1:03 pm
Posts: 1074
ECU Model: S40 Pro
Distributor: DTA
Firmware Version: 79
Title says S60?


Top
 Profile  
 
 Post subject: Re: S60 on a Suzuki Gsxr1000 K3/4
PostPosted: Thu May 11, 2017 2:53 am 
Offline

Joined: Sun Jan 27, 2013 6:08 pm
Posts: 254
ECU Model: S60 Pro
Firmware Version: 29
Stevieturbo muddying the waters - obsessed with P8's LOL!


Top
 Profile  
 
 Post subject: Re: S60 on a Suzuki Gsxr1000 K3/4
PostPosted: Thu May 11, 2017 3:28 am 
Offline

Joined: Thu Jul 28, 2011 4:10 am
Posts: 839
ECU Model: S100 Pro
S60 So it does! doh, I looked at his EUC Model so ignore my coil wiring


Top
 Profile  
 
 Post subject: Re: S60 on a Suzuki Gsxr1000 K3/4
PostPosted: Thu May 11, 2017 6:45 am 
Offline

Joined: Tue Aug 02, 2011 12:08 pm
Posts: 2883
Location: Norn Iron
ECU Model: No ECU
katana wrote:
Stevieturbo muddying the waters - obsessed with P8's LOL!


His sig thing states his ecu is P8 lol


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 26 posts ]  Go to page 1, 2, 3  Next

Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Theme designed by stylerbb.net © 2008
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
All times are UTC - 5 hours