Audi Quattro Turbo 5 cylinder on S80 wont start!

This section is dedicated to discussion of DTA engine control units such as the DTA E48 EXP, P8 Pro, DTA S40, S60, S80, and S100, as well as all things ECU related.

Re: Audi Quattro Turbo 5 cylinder on S80 wont start!

Postby mefmotorsport » Wed Dec 11, 2019 8:24 am

I might have just had a breakthrough on this one!

I just spoke to Allan, (the original owner of DTA), I explained the situation and straight away he said that you must wire the coils, not in the normal engine firing order, but in the order that the pistons come to the top of their stroke. select 10 cylinder (which we have done), nothing else. He said this will definitely be the problem and it will start straight away. He said determine what the order is by using a screwdriver down the bore of each cylinder in turn, then move the pins in the ecu connector accordingly.
User avatar
mefmotorsport
 
Posts: 542
Joined: Mon Aug 01, 2011 6:45 am
Location: Merseyside
ECU Model: S100 Pro
Distributor: Mefmotorsport
Firmware Version: 79

Re: Audi Quattro Turbo 5 cylinder on S80 wont start!

Postby stevieturbo » Wed Dec 11, 2019 1:52 pm

confused....

would that not be firing order then ?

In lieu of wiring changes, could you change the firing angles instead ?
stevieturbo
 
Posts: 3126
Joined: Tue Aug 02, 2011 12:08 pm
Location: Norn Iron
ECU Model: No ECU

Re: Audi Quattro Turbo 5 cylinder on S80 wont start!

Postby Rob Stevens » Wed Dec 11, 2019 2:02 pm

No, because one may be on its exhaust stroke.

I do recall seeing special instruction for the Audi 5 cyl engine and setting to 10 in general engine settings. But not sure where, probably in an old manual
Rob Stevens
 
Posts: 1038
Joined: Thu Jul 28, 2011 4:10 am
ECU Model: S100 Pro
Distributor: None-Coil On Plug :)

Re: Audi Quattro Turbo 5 cylinder on S80 wont start!

Postby stevieturbo » Wed Dec 11, 2019 5:06 pm

But presumably it's a wasted/twin spark...so both do actually fire anyway ? Or maybe not.

Yea, there was definitely some 5cy specific instructions at some point
stevieturbo
 
Posts: 3126
Joined: Tue Aug 02, 2011 12:08 pm
Location: Norn Iron
ECU Model: No ECU

Re: Audi Quattro Turbo 5 cylinder on S80 wont start!

Postby stevieturbo » Wed Dec 11, 2019 5:08 pm

P8 instructions

dta 5cyl p8.jpg
stevieturbo
 
Posts: 3126
Joined: Tue Aug 02, 2011 12:08 pm
Location: Norn Iron
ECU Model: No ECU

Re: Audi Quattro Turbo 5 cylinder on S80 wont start!

Postby mefmotorsport » Wed Dec 11, 2019 5:39 pm

Thanks Stevie,

the normal firing order as cast onto the cylinder head of this engine is 12453 so I will have to do the check and see what order the come to the top. I'm not sure about that injector order, how come cyls 3 & 4 on output 6? That doesn't look right.
I read on Wikipedia that there are only 2 variations of firing order on a 5 cylinder engine, 12453 or 15234 (as per the example you showed from the P8 wiring diagram special instructions.)

Martin
User avatar
mefmotorsport
 
Posts: 542
Joined: Mon Aug 01, 2011 6:45 am
Location: Merseyside
ECU Model: S100 Pro
Distributor: Mefmotorsport
Firmware Version: 79

Re: Audi Quattro Turbo 5 cylinder on S80 wont start!

Postby Alex DTA » Thu Dec 12, 2019 4:10 am

Interesting, I didn't know that. I'll dig in to the code and find out why.

However, there's no need for screwdrivers, when maths will do the trick.
A 5 cylinder engine fires every 720/5 = 144 degrees. Adding 360 degrees and adjusting so the values are within 0 - 720 degrees shows the plugs must be wired in 1-5-2-3-4 as per the P8 for this engine.
I would wire the injectors in firing order, so 12453.

Maths below for this engine:

Cyl 1 fires at 0 and TDC Exhaust is at 360
Cyl 2 fires at 144 and TDC Exhaust is at 504
Cyl 4 fires at 288 and TDC Exhaust is at 648
Cyl 5 fires at 432 and TDC Exhaust is at 72
Cyl 3 fires at 576 and TDC Exhaust is at 216

So the pistons will be at TDC at 0 (1), 72 (5), 144 (2), 216 (3) and 288 (4)

ETA:
Penny's dropped as to why this is.
There is no cam sensor, so the ECU doesn't know which cylinder is at TDC. It simply fires the outputs every 72 degrees, which is 360 / 5.

I'll update the S Series documentation to add this information somewhere.
Alex DTA
 
Posts: 1387
Joined: Fri Feb 28, 2014 1:03 pm
ECU Model: S40 Pro
Distributor: DTA
Firmware Version: 79

Re: Audi Quattro Turbo 5 cylinder on S80 wont start!

Postby mefmotorsport » Thu Dec 12, 2019 5:04 am

Excellent thanks Alex.
User avatar
mefmotorsport
 
Posts: 542
Joined: Mon Aug 01, 2011 6:45 am
Location: Merseyside
ECU Model: S100 Pro
Distributor: Mefmotorsport
Firmware Version: 79

Re: Audi Quattro Turbo 5 cylinder on S80 wont start!

Postby sogaard » Thu Dec 12, 2019 6:31 am

The audi i made last year i also got to run properly after it was set up as p8 instructions
sogaard
 
Posts: 7
Joined: Thu May 11, 2017 7:59 am
ECU Model: S60 Pro

Re: Audi Quattro Turbo 5 cylinder on S80 wont start!

Postby stevieturbo » Thu Dec 12, 2019 3:10 pm

So this engine just doesnt have an OEM cam sensor ?

And if it did have a phase sensor....everything would go back to normal ?
stevieturbo
 
Posts: 3126
Joined: Tue Aug 02, 2011 12:08 pm
Location: Norn Iron
ECU Model: No ECU

PreviousNext

Return to General

Who is online

Users browsing this forum: No registered users and 4 guests