It is currently Sun Dec 16, 2018 5:40 am



Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Rover K series experts?
PostPosted: Mon Sep 10, 2012 4:49 am 
Offline

Joined: Wed Mar 17, 2010 9:24 am
Posts: 329
ECU Model: S80 Pro
Firmware Version: 62
Hi

I'm borrowing my Dad's Rover 25 1.4 (2003 plate) and it's just started to chew through fuel. It normally fires up immediately, but now it needs several cranks to start from cold and it chucks out black smoke. It's never done this before.

I serviced it with new plugs, oil & air filter, fuel filter etc but it's still the same, so I'm guessing a component has failed. I've checked and there are no vacuum leaks.

Any ideas? Coolant temp sender maybe?

It's a completely standard car running the Rover ECU.


Top
 Profile  
 
 Post subject: Re: Rover K series experts?
PostPosted: Tue Sep 11, 2012 5:15 pm 
Offline

Joined: Tue Sep 06, 2011 7:13 am
Posts: 22
ECU Model: S60 Pro
Firmware Version: 78
could be coolant sensor or also they are comon for the front lambda sensor .


john


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Theme designed by stylerbb.net © 2008
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
All times are UTC - 5 hours